Re: [guide-user] Goto Named Stars 'bug'?

Bill Gray Aug 3, 2014

Hi Ben,

Yup, it's a bug. Guide tries to handle anything starting with 'A'
as an Abell galaxy cluster. With (for example) 'M', it's bright enough
to check that it's an 'M' followed by a number; if it is, then it
really is a Messier designation. But I didn't add that check for
Abell galaxy clusters. So it regards 'Altair', 'Aldebaran', etc.
as improperly formed Abell galaxy clusters, and gives up.

I'll post a fix for this, probably late in the week... my wife
has scheduled a camping trip, which will probably take me away before
I can post the fix. (The fix is actually quite simple, and is done.
The problem is that I've also been working on improving Guide's error
checking, as described in my previous message, so that when it can't
open files, it will tell you something like "don't have permission to
open this" or "it's read-only" or "it doesn't exist". This is about
half-done; I can't post it until it's done.)

By the way, the list of star names is in 'common2.nam'. Should be
in your Guide folder, duplicated in the 'text' folder below it.

-- Bill

On 08/03/2014 04:03 PM, Ben Hudgens bhudg3079@... [guide-user] wrote:
> I'm using the current version of Guide 9 and recently found what may be
> a bug or possible corrupt file.
>
> When using Goto, 1st choice(object name), enter a bright star name,
> anything starting with "A" results with an error "not a valid object".
> I've tried dozens of named stars and goto works with any of them except
> those like Altair, Aldebaran, Arcturus, etc.
>
> Anyone else seeing this problem?
> Ben Hudgens
>
>
>
> ------------------------------------
> Posted by: Ben Hudgens <bhudg3079@...>
> ------------------------------------
>
> To unsubscribe from this group, send an empty email to:
> guide-user-unsubscribe@egroups.com
> ------------------------------------
>
> Yahoo Groups Links
>
>
>
>